MENU

Cisco 1812Jの設定方法 その2(PPPoE、ダイナミックDNSなど)

Cisco 1812Jの設定方法 その2(PPPoE、ダイナミックDNSなど)です。
以下を設定しました。

・コンフィグの消去

 

・DHCPサーバーの設定

 

・PPPoEの設定

 

・DDNSの設定

 

 

以下の流れでDHCPサーバ設定とPPPoE設定などを行います。

1812J#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
reload
System configuration has been modified. Save? [yes/no]: no
Proceed with reload? [confirm]
*Dec 3 12:43:46.083: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload Command.
Would you like to enter the initial configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>en
Router#sh flash
-#- --length-- -----date/time------ path
1 28467800 Apr 30 2010 07:22:32 c181x-adventerprisek9-mz.151-1.XB.bin
3461120 bytes available (28471296 bytes used)
Router#clock set 22:04:00 Dec 3 2011

Dec 3 13:04:00.000: %SYS-6-CLOCKUPDATE: System clock has been updated from 22:04:09 JST Fri Jun 3 2011 to 22:04:00 JST Sat Dec 3 2011, configured from console by console.
Router#conf t
Router(config)#line console 0
Router(config-line)#exec-timeout 0 0
Router(config-line)#logging synchronous
Router(config-line))#exit
Router(config)#int vlan 1
Router(config-if)#ip add 172.16.0.1 255.255.255.0
Router(config-if)#ip tcp adjust-mss 1414
Router(config-if)#exit
Router(config)#ip dhcp excluded-address 172.16.0.1
Router(config)#ip dhcp pool LAN
Router(dhcp-config)#network 172.16.0.0 255.255.255.0
Router(dhcp-config)#dns-server ***.***.**.**
Router(dhcp-config)#default-router 172.16.0.1
Router(dhcp-config)#exit

Router(config)#int fa 0
Router(config-if)#no ip address
Router(config-if)#pppoe enable
Router(config-if)#pppoe-client dial-pool-number 1
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int Dialer 0
Router(config-if)#ip address negotiated
Router(config-if)#encapsulation ppp
Router(config-if)#dialer pool 1
Router(config-if)#dialer-group 1
Router(config-if)#ppp authentication chap callin
Router(config-if)#ppp chap hostname ***@***.so-net.ne.jp
Router(config-if)#ppp chap password **********
Router(config-if)#ip mtu 1454
Router(config-if)#exit

Router(config)#dialer-list 1 protocol ip permit
Router(config)#interface vlan 1
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#interface Dialer 0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#access-list 1 permit 172.16.0.0 0.0.0.255
Router(config)#ip nat inside source list 1 interface Dialer 0 overload
Router(config)#ip route 0.0.0.0 0.0.0.0 Dialer 0
Router(config)#exit

 

その後、
show ip dhcp binding
でDHCPの払い出し状態、
debug ppp negotiation
debug pppoe events
debug ppp authentication
でpppoeの状態確認を行いました。
debug ppp negotiation の出力について

 

DDNS設定は以下のサイトが参考になりました。
kdns.jp howto cisco

 

ダイナミックDNSは「dyndns」を使用しました。
http://dyn.com/dns/

 

dyndnsのWEBサイトによるダイナミックDNSの設定は
例示しませんが、以下のサイトが詳しいです。
http://kajuhome.com/dyndns.shtml

 

(config)#ip name-server 8.8.8.8
(config)#ip ddns update method ddns_method_name
(DDNS-update-method)#HTTP
(DDNS-HTTP)#add http://ユーザー名:パスワード@
members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

 

本コマンド投入時の注意事項

コマンド文字列に疑問符「?」を加える場合は、
CLI ヘルプを誤って起動しないように Ctrl-V を押してから、
疑問符を入力する必要があります。
「?」はペーストでの投入では入力されず、エラーも出ません。
ですので最終行の〜updateまでをペーストし、Ctrl-V を押した後「?」キーを入力し、
続けてsystem〜をペーストし投入します。

 

投入後、show running-configにて「?」も含め正しく投入された事を確認する
ことが大事です。

 

今後、コンフィグの全貼り付けによるルータの設定を「?」部分も含めて流し込んだとしても
実際には「?」は投入されていません。
ですのでinterface FastEthernetのno shutdownと同じく、この部分の「?」も
入れてあげなければなりません。
もしかするとteratermの設定等で「?」もペーストできるのかもしれませんが未確認です。

 

(DDNS-HTTP)#exit
(DDNS-update-method)# interval maximum 14 0 0 0
(DDNS-update-method)# exit
(config)#interface Dialer0
(config-if)#ip ddns update hostname ユーザー名.dyndns-server.com
(config-if)#ip ddns update ddns_method_name
debug ip ddns update

 

※reload後の起動時
Translating "members.dyndns.org"...domain server (8.8.8.8) [OK] とログ表示後のタイミングで、
dyndnsのMyページをF5キーにて更新し、IPが正しく変更されたことも確認しておきます。