MENU

Cisco 基本コマンドについて

Ciscoの基本コマンドについての紹介です。

 

よく使うコマンド

 

pingやtracerouteをキャンセル

「Ctrl」 + 「Shift」+ 「6」

 

コンソール接続時にタイムアウトによりログアウトしないように設定する

Router(config-line)#exec-timeout 0 0

※exec-timeout 分 秒

 

ルータからのメッセージを割り込ませない

Router(config-line)#logging synchronous

vtyにも設定可能

 

DNSサーバーを利用したホスト名の名前解決を無効にする

Router(config)#no ip domain-lookup

 

コンフィグモードでのshow running-config

do sh run

 

本ページの目次
●ユーザ・特権・グローバルコンフ・インターフェイスコンフモード
●コマンドヘルプ
●コマンド入力サポート
●エラーメッセージ

 

●パスワードの設定
●パスワードを暗号化する(enable secret以外も)
●インターフェースの設定
●リンクアップの確認
●ping
●インターフェースに説明文
●ルータにログインする際にバナーメッセージ(messege of the day)を表示させたい

 

●ルータの初期化(ルータの設定を削除)
●config の保存と削除
●config を確認
●show running-configのときに---more---を出さない
●show version の確認(コンフィグレーションレジスタの値も含む)
●show flash の確認
●現在の設定を保存
●再起動
●ルータを名付ける
●タイムアウトしない設定
●ルータからのメッセージを割り込ませない
●DNSサーバーを利用したホスト名の名前解決を無効にする

 

●コンフィグレーションレジスタの値の変更と確認
●ルータ起動時にCisco IOSを検索する場所をBootstrapに指定
●IOSのバックアップとリカバリ
●コンフィグのバックアップとリカバリ
●複数台の接続
●telnet
●カプセル化の確認
●CDPについて
●ホスト名の名前解決を行う
●サブネットIDについて/ IPサブネットゼロを有効にする

 

●Ciscoルータでは通常コマンドにnoをつけることによって設定を解除できます。
●コンフィグを流し込む
●イーサネットポートにPCを繋がずにEthernetインターフェイスをアップにする
●エイリアス(show aliases)について(省略コマンド)
●複数のルータをターミナルサーバで操作する

 

●ルーティングテーブルを確認する
●プロコトルを確認する
●スタティックルート
●デフォルトルートを設定する
●RIPを設定する
●ルーティングプロトコルがやり取りしている情報を確認する(デバッグ)
●スプリットホライズンについて
●パッシブインターフェイスの設定

 

 

 

以下から、本章を記載します。

 

ユーザモード「Router」から出る(ログアウト)

exit
quit
logout

 

 

特権モード「Router#」に入る

enable
●略 en

 

 

特権モード「Router#」から出る

disable

 

 

特権モード「Router#」からログアウトする

exit
quit
logout

 

 

グローバルコンフィグレーションモード「Router(config)#」に入る

Router#configure terminal
●略 cnf t

 

 

グローバルコンフィグレーションモード「Router(config)#」から出る

Router(config)#exit
Router(config)#end
Router(config)#●ctrl+z●

 

 

特定のコンフィグレーションモード(インターフェイスコンフィグレーションモード)「Router(config-if)#」に入る

Router((config)#interface FastEthernet 0/1●略●int e0/1
Router((config)#line console 0

 

 

コンソールに入る

Router(config)#line console 0

 

 

特定のコンフィグレーションモード(インターフェイスコンフィグレーションモード)

「Router(config-if)#」から出る

Router(config-if)#exit

 

 

特定のコンフィグレーションモード(インターフェイスコンフィグレーションモード)

「Router(config-if)#」から特権モードに出る

Router(config-if)#end
Router(config-if)#●ctrl+z●

 

コマンドヘルプ

●コマンドリストヘルプ
?のみを入力

 

●コマンド補完ヘルプ
文字列の直後に?

 

●コマンド構文ヘルプ
コマンドの後に空白を入れて?

 

 

コマンド入力サポート

tabキー・・・入力途中のコマンドの綴りを自動的に補完する。
ctrl+p ・・・直前に入力したコマンドを呼び出す
ctrl+a ・・・文の先頭に移動
ctrl+e ・・・文末に移動

 

 

エラーメッセージ

% Ambiguous command:
入力文字数が不十分でコマンドを認識できない。

 

% Incomplete command.
入力したコマンドの構文が不完全である。

 

% Invalid input detected at '^' marker.
キャレット記号の部分に誤りがある。

 

 

パスワードの設定

 

暗号化されない特権パスワードの設定

Router(config)#enable password aaaaaa

 

暗号化される特権パスワードの設定

Router(config)#enable secret aaaaaa

 

コンソールパスワードの設定

Router(config)#line console 0
Router(config-line)#login
Router(config-line)#password aaaaaa

 

vty(telnet)パスワードの設定

Router(config)#line vty 0 4
Router(config-line)#login
Router(config-line)#password aaaaaa

 

パスワードの暗号化

Router(config)#service password-encryption

 

 

インターフェースの設定

 

configモードからインターフェースモードに移行します。
イーサーインターフェースの場合はこうなります。

Router(config)#interface ethernet 0

↑この部分が設定するインターフェースの番号
機器によっては、0/0みたいに書きます。
これで、ethernet 0/0のインターフェースを設定することが出来ます。
(省略する場合は、int e0/0でいい)

Router(config-if)#

 

シリアルインターフェースの場合はこうなります。

Router(config)#interface serial 0

インターフェスの指定の仕方はetehrnetと一緒。
これで、serial 0のインターフェースを設定することが可能になる。
●略 (省略する場合は、int s0やint e 0、int e 0/0でいい)

 

Router(config-if)#
IPアドレスを設定するには、
Router(config-if)#ip address 192.168.1.1 255.255.255.0
インターフェースのアドレスと、サブネットマスク

 

ルータの場合はインターフェースはシャットダウンされてるので

Router(config-if)#no shutdown

と打ってインターフェスを立ち上げる(シャットダウンする時はshut)

 

serialの場合は、DCE側からクロックを供給する必要があるので
以下を入力します。

Router(config-if)#clock rate 64000

クロックの速度。

 

IPアドレスを消す場合は

Router(config-if)#no ip address

 

シャットダウンする場合は

Router(config-if)#shutdown

 

2つ目のIPアドレスを設定するには、

Router(config-if)#ip address 192.168.1.2 255.255.255.0 secondary

 

IPアドレスを消す場合は、必ず2つ目のIPアドレスから削除する。

Router(config-if)#no ip address 192.168.1.2 255.255.255.0 secondary

 

リンクアップの確認

Router#show interface ethernet 0

物理層、データリンク層がともにupならOK。

 

 

ping

普通にルータへping。

ping 192.168.1.1

!!!!!ならOK。.....なら失敗。

 

インターフェースに説明文

Router(config-if)#description aaaaa

 

 

ルータにログインする際にバナーメッセージ(messege of the day)を表示させたい

Router(config)#banner motd"区切り文字(#)など"
aaaaaa #

 

 

 

ルータの初期化(ルータの設定を削除)

Router#erase startup-config

その後reload

 

 

config の保存と削除

コンフィグの保存

Router#wr mem

 

running-configをstartup-configに保存

copy running-config startup-config

●略 copy run start

 

startup-configのつづりを間違えた場合、ルータはそれをFlash内に

保存しようとしてFlash内のIOSを削除しようとします。
IOS消去の承認を聞かれるので必ずnoにする。

 

 

startup-configの設定を削除

Router#erase startup-config

 

NVRAMにstartup-configが無いことを確認

Router#show startup-config

 

 

configの確認

今機器を動かしているconfigを見るには

Router#show running-config

 

機器を再起動させた時読み込むconfigを見るには

Router#show startup-config

 

 

show running-configのときに---more---を出さない

Router>en
Router#ter len 0
Router#s run

「ter len」はterminal lengthの略で端末の行数指定なのですが、
0を指定すると、show running-configのときに---more---がでなくなる。
ログを取ると、---more---が変な化け文字でログに残るため ter len 0 が良い。

 

 

version の確認(コンフィグレーションレジスタの値も含む)

Router#show version

 

 

flash の確認

Router#show flash

 

 

現在の設定の保存

Router# copy running-config startup-config

●略 copy run start

 

 

再起動

特権モードで

Router#reload

と打ちます

System configuration has been modified. Save? [yes/no]:

 

configを保存するか聞いてきますので、y or nで回答後エンターを押す。

System configuration has been modified. Save? [yes/no]: y

Building configuration...
[OK]

Proceed with reload? [confirm]

 

再起動する。
起動時configが無いと以下を聞かれる。

 

Would you like to enter the initial configuration dialog? [yes/no]: n
Would you like to enter the initial configuration dialog? [yes/no]:

間違ってyにすると、

Would you like to enter basic management setup? [yes/no]:

となる。

 

Ctrl + cで抜けられる。

 

 

ルータを名付ける

Router(config)#hostname aaaaaa

 

 

コンソール接続時にタイムアウトによりログアウトしないように設定する

Router(config-line)#exec-timeout 0 0  ←exec-timeout 分 秒

 

 

ルータからのメッセージを割り込ませない

Router(config-line)#logging synchronous

vtyにも設定可能

 

 

DNSサーバーを利用したホスト名の名前解決を無効にする

Router(config)#no ip domain-lookup

 

 

 

コンフィグレーションレジスタの値の変更と確認

Router(config)#config-register 0x2101

 

 

ルータ起動時にCisco IOSを検索する場所をBootstrapに指定

 

tftpから

Router(config)#boot system tftp aaaaa.bin 192.168.1.100

flashから

Router(config)#boot system flash aaaaa.bin

romから

Router(config)#boot system rom

 

 

再度設定すると、IOSを検索する場所が入れ替わるのでは無くて、
startupconfigに行が追加される。
なので消す場合はstartupconfigを(tftpに移したりして)
書き換えて設定する。

 

 

IOSのバックアップとリカバリ

 

バックアップ

copy flash tftp

 

リカバリ

copy tftp flash

基本的にはリカバリする時に中のflashを消すか聞かれる。

 

現在稼動中のflashは消せないかも。その際はルータ起動時に
Cisco IOSを検索する場所をtftpに変えてから。(作業後、元に戻しておく)

 

フラッシュメモリの内容を全て削除する場合は

erase flash

 

スイッチの場合:まずflashの中身を消すにはdelete flash:aaaaa.bin

 

 

コンフィグのバックアップとリカバリ

copy run tftp

 

copy tftp run
→host
→192.168.1.100

 

残ってた設定はマージされる。
(書き換えない設定は残ったままになるということ)

 

なので全て新しく書き換える場合は
startup configを消す。

erase start

 

その後ipとno shutだけ設定する。
それでtftpからコピーする。
copy tftp run

 

 

複数台の接続

back-to-back DB60cable

Ethernetとは別のセグメントを使用。
clock rate 64000
link up up
DTE/DCEの、どちら側かの確認は

router#show controllers s 0/0

DCEが供給する側、DTEが供給される側

 

 

telnet

対象ルータにvtyパスワードが設定していないと入れない

 

 

カプセル化タイプの確認

router#(config-if)#encapsulation ppp

 

確認方法はshow interfaceコマンドで
「encapsulation HDLC」か「encapsulation PPP」を確認。

 

・データリンク層のプロコトルには「HDLC」と「PPP」がある。

 

・Ciscoルータのシリアルインターフェイスのデフォルトの

カプセル化タイプは「HDLC」である。

 

・プロコトルが異なると通信出来ない。

 

 

CDPについて

 

・CDPをイネーブルにしたCisco デバイスは、近隣装置に自分を認識させるため
マルチキャストアドレスにインターフェイスアップデートを定期的に送信します。

 

・レイヤ 2 プロトコルであるため、これらのパケット(フレーム)は
ルーティングされません。

 

・メディアやプロトコルに依存しないシスコ独自の
レイヤ2プロトコルであり、次の装置を含むシスコが製造した全装置で
動作します。ルータ、ブリッジ、アクセスサーバ、スイッチ

 

CDPの有効か無効、CDPの更新間隔とホールドタイム値の確認。
(デフォルトは各60秒、180秒)

 

※CDPホールドタイム値・・・近隣デバイスから受信したパケットを
保持(ホールド)する時間

 

show cdp

 

上記に加えインターフェイスの状態とカプセル化タイプも表示させるには

show cdp interface

 

隣接ルータの情報を表示

show cdp neighbors

 

隣接ルータの情報を表示に加えレイヤ3情報(IPアドレスなど)を表示する。
レイヤ3情報が表示されるのは下記2つのコマンドのみ。

show cdp neighbors detail
show cdp entry *

 

 

ホスト名の名前解決を行う

router(config)# ip host ホスト名 IP
例:router(config)# ip host routeraaa 192.168.30.2

 

 

サブネットIDについて/ IPサブネットゼロを有効にする

router(config)# ip subnet-zero

 

IPサブネットゼロが無効の場合

・サブネットIDの部分が全て0、及び全て1の場合、ルータの
インターフェイスにはそのIPは使えない。

 

ip subnet-zeroは、IOS Ver12.0以降ではデフォルトで有効。
IPサブネットゼロは設定すると、そのルータ全体に反映される。

 

 

Ciscoルータでは通常コマンドにnoをつけることによって設定を解除できます。

no

 

コンフィグを流し込む

 

入れたいコンフィグを全行コピペする。
show runコマンドではno shutdownコマンドは入っていないので、それは
コピー前に追加しておくか、流し込み後に入れる。

 

「?」を流すには注意

ダイナミックDNS設定時など、コマンド文字列に疑問符「?」を加える場合は
CLI ヘルプを誤って起動しないように Ctrl-V を押してから、
疑問符を入力する必要があります。
「?」はペーストでの投入では入力されず、エラーも出ません。
ですので最終行の〜updateまでをペーストし、Ctrl-V を押した後「?」キーを入力し、
続けてsystem〜をペーストし投入します。

 

投入後、show running-configにて「?」も含め正しく投入された事を確認する
ことが大事です。

 

今後、コンフィグの全貼り付けによるルータの設定を「?」部分も含めて流し込んだとしても
実際には「?」は投入されていません。
ですのでinterface FastEthernetのno shutdownと同じく、この部分の「?」も
入れてあげなければなりません。
もしかするとteratermの設定等で「?」もペーストできるのかもしれませんが未確認です。

 

 

イーサネットポートにPCを繋がずにEthernetインターフェイスをアップにする

router(router-if)#)no keepalive

 

CiscoルータのEthenetインターフェイスは、独自のキープアライブフレームを
自分あてに10秒間隔で送出し、そのフレームが確認できた場合は
Ethenetインターフェイスがupしているとみなしています。
そのキープアライブを停止させると、ずっとupと認識するようになる。
そのインターフェイスにpingも飛ぶようになる。

 

 

エイリアス(show aliases)について(省略コマンド)

s runでも表示できます。これをエイリアスといいます。

p (ping)

show aliasesで見てみましょう。

 

複数のルータをターミナルサーバで操作する

複数のルーターを操作するときは
ターミナルサーバー(Cisco2509やCisco2511など)が有る。
「Octalケーブル」と呼ばれる八またのケーブルの1つをコンソール・ポートにつなぎます。
ターミナルサーバーにログインして,そこから他の機器にTelnetする。

 

ターミナルサーバー経由で他の機器にTelnetすることをリバースTelnetと言う。

 

 

ルーティングテーブルを確認する

router#show ip route
S 192.168.4.0/24 [1/0] via 192.168.2.2 ←スタティックルート
S 192.168.5.0/24 [1/0] via 192.168.2.2 ←スタティックルート
C 192.168.1.0/24 is directly connected, Ethernet0/0 ←直接接続されたインターフェイス
C 192.168.2.0/24 is directly connected, Serial0/0 ←直接接続されたインターフェイス
S 192.168.3.0/24 [1/0] via 192.168.2.2 ←スタティックルート

 

S はスタティックルート
S* はデフォルトルート
C は直接接続されたインターフェイス
R はRIPで覚えたルート

 

 

プロコトルを確認する

router#show ip protocols

プロトコルやアドミニストレーティブディスタンスの値などの確認をする。

 

スタティックルート

router(config)#ip route 宛先ネットワーク サブネットマスク ネクストホップアドレス
router(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2

 

自ルータの知らないネットワークを追加するため
そのルータ全体に反映される。

●必ず往復のルートを設定する。
●往路のみの設定だとエコー要求は行っても、エコー応答が返せない。

 

※ネクストホップアドレスは隣接ルータのインターフェイスのIPアドレスです。
(自ルータと同一ネットワークのもの)

 

 

デフォルトルートを設定する

router(config)#ip route 0.0.0.0 0.0.0.0 ネクストホップアドレス

 

通常、ルータはルーティングテーブル上に無いネットワーク宛ての
パケットは破棄しますが、デフォルトルートの設定をしておくと
そのアドレス宛てのパケットを配送することが可能。

 

classlessコマンドを有効にしておかなければならない。

 

クラスフル・・・ネットワーク内でマスクの一貫性が必要
クラスレス・・・垣根を越えた配送が可能

 

router#show ip routeコマンドで、
S* はデフォルトルート

 

 

RIPを設定する

router(config)# router rip ←RIPの設定モードに入る
network 192.168.1.0 ←192.168.1.xのインタフェースでRIPを動かす

 

自分の持っているネットワークを他のルータに教えあう。

 

※RIPにはサブネットを扱えないという欠点があるため、
ネットワークを構築する際は、ネットワーク内でサブネットの大きさを
同じにしておく考慮が必要になります。

 

 

ルーティングプロトコルがやり取りしている情報を確認する(デバッグ)

RIPがやり取りしている情報を確認する

debug ip rip

 

※デバッグ機能はルーターに対して非常に大きな負荷をかける。
そのため、デバッグの動作中、ルーターは本来の能力を
発揮できないことがある。

 

 

スプリットホライズンについて

AAAルータからアドバタイズされた(教えてもらった)
ルートに関しては、AAAルータにはルーティング情報を送り返さない。
ルーティングループを防ぐため。

 

 

パッシブインターフェイスの設定

router(config)# router rip
router(config-router)# passive-interface s 0/0

 

パッシブインターフェイスでは、RIPアップデートを受信しますが
送信はしません。