MENU

Cisco VLANの設定方法

VLANへのIPアドレス設定について

スイッチ(catalyst2950)のIPアドレス設定を行います。

 

管理VLAN(VLAN1)に設定するならば、

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.0.10 255.255.255.0

 

トランク接続(タグVLAN)について

 

MACフレームにVLAN情報を付加して送信する。
トランク・プロトコルは以下の2つ。

@ISL Cisco独自
AIEEE802.1Q 標準

 

 

 

今回は以下の構成を作成しました。

 

 

■S1に設定を入れていきます。

S1(config-if)#int fa 0/1

 

S1(config-if)#switchport mode trunk

 

S1(config-if)#no shut

 

S1(config)#int fa 0/5

 

S1(config-if)#switchport mode access

 

S1(config-if)#switchport access vlan 5

 

S1(config-if)#no shut

 

S1(config)#int fa 0/10

 

S1(config-if)#switchport mode access

 

S1(config-if)#switchport access vlan 10

 

S1(config-if)#no shut

 

 

■S2に設定を入れていきます。

S2(config-if)#int fa 0/1

 

S2(config-if)#switchport mode trunk

 

S2(config-if)#no shut

 

S2(config)#int fa 0/5

 

S2(config-if)#switchport mode access

 

S2(config-if)#switchport access vlan 5

 

S2(config-if)#no shut

 

S2(config)#int fa 0/10

 

S2(config-if)#switchport mode access

 

S2(config-if)#switchport access vlan 10

 

S2(config-if)#no shut

 

 

■ping確認

PC1からPC3へは疎通できることを確認します。
PC1からPC2,PC4へは疎通できないことを確認します。

 

 

トランク接続で特定のVLANのみ許可

S1(config)#int fa 0/1

 

S1(config-if)#switchport trunk allowed vlan 10

 

※複数選択の場合はallowed vlan 8,9,10

 

 

トランク対応ルータでのVLAN設定

 

 

以下の構成を作成しました。

 

 

 

設定方法は以下です。

■R1

Cisco7200を使用しました。

●スロットにFEのモジュールを取り付け、サブインターフェイスを作成し、設定していきます。

 

R1(config)#int fa 1/0.1

 

R1(config-subif)#encapsulation dot1Q

 

R1(config-subif)#encapsulation dot1Q 5

 

R1(config-subif)#ip add 192.168.1.100 255.255.255.0

 

R1(config-subif)#no shut

 

R1(config)#int fa 1/1.1

 

R1(config-subif)#encapsulation dot1Q

 

R1(config-subif)#encapsulation dot1Q 10

 

R1(config-subif)#ip add 192.168.2.100 255.255.255.0

 

R1(config-subif)#no shut

 

R1(config)#int fa 1/1.2

 

R1(config-subif)#encapsulation dot1Q 15

 

R1(config-subif)#ip add 192.168.3.100 255.255.255.0

 

R1(config-subif)#no shut

 

■SW1

fa 1/1 トランクポート

 

fa 1/5 VLAN 5

 

■SW2

fa 1/1 トランクポート

 

fa 1/7 VLAN 10

 

fa 1/8 VLAN 15

 

■「サーバー見立て」と「クライアント見立て」

fa0/0へのIPアドレス設定と
デフォルトルートのみ設定しています。

 

R4からR6にも疎通可能です。